Supported Platforms

This page shows the supported platforms for Clover 4.1.x and its minor releases.

Key: (tick) = Supported; (error) = Not Supported

Java Version

JRE / JDK (1)

(tick) 1.6 - 1.8

Groovy Version

Groovy

(tick) 1.6.2 or later
(error) 1.6.8, 1.6.9 and 1.7.1 do not support Per-Test coverage due to a Groovy bug
(error) 2.0.0 does not work with JDK1.5 due to a Groovy bug
(error) Eclipse and IDEA (No Groovy support in IDE)

JRE / JDK (1)

(tick) 1.6 or later

Operating Systems

Microsoft Windows (2)

(tick)

Linux (2)

(tick)

Apple Mac OS X (2)

(tick)

Build Automation Tools

Apache Ant

(tick) 1.7.0 or later

Apache Maven 2

(tick) 2.0.2 or later

Apache Maven 3

(tick) 3.0.0 or later

Application Development Frameworks

Grails

(tick) 2.0 - 2.5 (6)

Integrated Development Environments (IDEs)

JetBrains IntelliJ IDEA

(tick) 11.0 - 2016.3 (5)

Eclipse (3)

(tick) 4.2 (Juno) - 4.6 (Neon), RAD 9 (4)

Web Browsers (for viewing Clover's HTML report)
Internet Explorer (tick) 9.0 or later
Firefox (tick)
Chrome (tick)

Supported Platform Notes

  1. JDK 1.8 is supported since Clover 3.2. The last Clover version supporting JDK/JRE 1.4 is 3.1.12. The last Clover version supporting JDK/JRE 1.5 is 3.3.x. Since Clover 4.0 you must use at least Java 1.6 for compilation and runtime. Please note that it's still possible to set source level = 1.3 (no assert keyword) or 1.4 (no enums, generics) or 1.5 (no @Override on interfaces) for instrumentation.
    You can download a JRE or JDK for Windows/Linux. On Mac OS X, a JDK is bundled with the operating system. Once a JRE or JDK has been installed, you need to set the JAVA_HOME environment variable.

  2. Clover is a pure Java application and should run on any operating system platform provided the requirements for the JRE or JDK are satisfied. Clover does not work on Solaris OS due to bugs in NIO implementation in Java on this platform.

  3. Your Eclipse projects must use the built-in Java Builder for compilation of source code. Clover does not support AspectJ-based projects.

  4. Support for Eclipse 3.6 and 3.7 as well as RAD 8 and RAD 8.5 has ended with Clover 4.1.0. The Eclipse 4.6 is supported since Clover 4.1.2.

  5. The IDEA 12 is supported since Clover 3.1.8. If you're using IDEA 12.0.x and Clover 3.1.8-3.1.11 then you have to disable the "external build" feature. The IDEA 13.0 is supported since Clover 3.2.1. The IDEA 13.1 is supported since Clover 3.3.0. For IDEA 14.0 we recommend Clover 4.0.3 or later. The IDEA 15.0 is supported since 4.1.0. The IDEA 2016 is supported since 4.1.2.

  6. Support for Grails 1.3 has ended with Clover 4.1.0.

 

End of Platform Support Announcements

 

Last modified on Jan 16, 2017

Was this helpful?

Yes
No
Provide feedback about this article

Not finding the help you need?

Ask the community

Powered by Confluence and Scroll Viewport.