Confluence Manage apps hung and display "A long-running task has been initiated by another user." while installing third-party plugin.
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Confluence Manage Apps page hung while installing/updating a third party plugin. The following message appear in the Manage Apps page:
A long-running task has been initiated by another user. To avoid conflicts, you will not be able to update apps until this task has completed.
Environment
Confluence Server / Data Center
Diagnosis
Third-party plugin installation/update hung on the Manage Apps page which potentially caused Confluence to crash.
Cause
Java version incompatibility error below appears in the atlassian-confluence.log:
Caused by: java.lang.UnsupportedClassVersionError: co/uk/automationconsultants/compliance/helper/SpaceHelper has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
This error is related to Compliance for Confluence plugin version 5.4.1 which was compiled against Java 11 and Confluence was running with Java 8.
Note: class 52 = Java 8 and class 55 = Java 11
Solution
The following options will help to resolve the issue:
Solution 1
- Update the Java version that is used to run Confluence to Java 11. (Kindly refer to Change the Java vendor or version Confluence uses for more details)
Solution 2
- Upload an older version of the plugin which is compiled against Java 8
Solution 3
- Contact the vendor to get help regarding the lack of Java 8 support.