Page Not Found when navigating to Manage Add-Ons (UPM: /plugins/servlet/upm)
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
Navigating to Confluence Admin >> Manage Add-Ons results in Page Not Found. The URL shows the correct path: http://<ConfluenceURL>/plugins/servlet/upm
Cause
- Either corrupted plugin caches, or the UPM fails to startup due to this: Plugins are disabled at startup and various timeout errors appear in the logs after startup
- It is also possible that the issue is due to compatibility of Atlassian Universal Plugin Manager Plugin with the Confluence version
Resolution
For Cause 1
Shutdown Confluence, then remove the following from the Confluence Home Directory (refer to Confluence Home and other important directories for more information):
bundled-plugins
plugins-cache
plugins-osgi-cache
plugins-temp
After that, startup Confluence. If that does not solve the issue, please refer to this article: Plugins are disabled at startup and various timeout errors appear in the logs after startup (the UPM may not be starting up due to a timeout)
For Cause 2
Verify the version of the Atlassian Universal Plugin Manager Plugin and compare it against the below page where it shows the support versions on the second column:
If you have incompatible version of the Atlassian Universal Plugin Manager Plugin with the Confluence, please follow the below steps:
Confluence stores add-ons such as UPM in its database, so the process for updating it by file replacement is a little different to other products.
To update the UPM file in Confluence:
- Download the UPM JAR from the Atlassian Marketplace.
- Stop Confluence.
- Remove the existing UPM JAR file from
<install-directory>/confluence/WEB-INF/atlassian-bundled-plugins
. - Copy the new UPM JAR file into the same directory.
- Clear the Confluence plugins cache.
Downgrading only:
Always back up your data before performing any modifications to the database. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.
DELETE FROM plugindata WHERE pluginkey LIKE 'com.atlassian.upm.atlassian-universal-plugin%';
- Restart Confluence