Plugins Fail After an Upgrade to Java 1.7

Still need help?

The Atlassian Community is here for you.

Ask the community


Dashboard plugins are non-functional after an upgrade of the JDK from Java 1.6 to Java 1.7

The following appears in the atlassian-confluence.log:

2013-02-15 12:53:34,620 ERROR [main] [plugin.osgi.factory.OsgiPlugin] enableInternal Detected an error (BundleException) enabling the plugin 'com.atlassian.activeobjects.activeobjects-plugin' : Unresolved constraint in bundle com.atlassian.activeobjects.activeobjects-plugin [26]: Unable to resolve 26.0: missing requirement [26.0] package; (&(package=com.atlassian.activeobjects.spi)(version>=0.17.0)) [caused by: Unable to resolve 27.0: missing requirement [27.0] package; (&(package=javax.sql)(version>=<=].  This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see
2013-02-15 12:53:34,622 WARN [main] [plugin.osgi.factory.OsgiPlugin] enable Unable to enable plugin 'com.atlassian.activeobjects.activeobjects-plugin'
com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.activeobjects.activeobjects-plugin
        at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(
        at com.atlassian.plugin.impl.AbstractPlugin.enable(
        at com.atlassian.plugin.impl.AbstractDelegatingPlugin.enable(


A bug in Plugin system:

Confluence 5.0 has a newer version of the Plugin system with the bug fixed.



This can be resolved immediately by:

In order to avoid the issue in the future, you can upgrade your instance to Confluence 5.0 or newer versions.


Last modified on Nov 2, 2018

Was this helpful?

Provide feedback about this article
Powered by Confluence and Scroll Viewport.