Connector CAPTCHA_CHALLENGE error on Jira Align Connector
Summary
When there are too many incorrect login attempts to Jira using the Jira Align user that is configured on the connector, Jira will prompt a Captcha challenge, which will stop the sync between JA <> Jira.
Environment
Jira Align
Diagnosis
The error below can be observed on the Splunk, or on the Connector logs found on Administration > Jira Settings > Manage Projects > View Logs: Issues:
AgileCraft.Jira.Api.Model.JiraApiException: RequestResource:https://<jira_url>/jira/rest/api/2/serverInfo?doHealthCheck=true,
RequestMethod:GET, ResponseStatus:Error, ResponseStatusCodeExpected:200,
ResponseStatusCodeDescriptionExpected:OK, ResponseStatusCode:403, ResponseStatusCodeDescription:Forbidden,
ResponseHeader_x-arequestid:940x10854090x1, ResponseHeader_referrer-policy:strict-origin-when-cross-origin,
ResponseHeader_x-xss-protection:1; mode=block, ResponseHeader_x-content-type-options:nosniff,
ResponseHeader_x-frame-options:SAMEORIGIN, ResponseHeader_content-security-policy:frame-ancestors 'self',
ResponseHeader_strict-transport-security:max-age=31536000, ResponseHeader_x-seraph-loginreason:AUTHENTICATION_DENIED,
ResponseHeader_x-asessionid:1x9hx7q, ResponseHeader_x-authentication-denied-reason:CAPTCHA_CHALLENGE;
login-url=https://<jira_url>/jira/login.jsp, ResponseHeader_transfer-encoding:chunked,
ResponseHeader_Content-Type:text/html;charset=UTF-8, ResponseHeader_Date:Sat, 27 Nov 2021 15:40:01 GMT,
ResponseHeader_Set-Cookie:JSESSIONID=1E95E6C4F921F1F33A985F046E3818F3; Path=/jira; Secure; HttpOnly,
ResponseHeader_WWW-Authenticate:OAuth realm="<jira_url>"
Cause
This can occur when failed login attempts or some sort of communication interruption happens between Jira Align and Jira. When the Jira Connector service account reaches the failed login attempt count for this user on the Jira side, Jira then triggers a CAPTCHA_CHALLENGE message that the user would need to complete. Since this is an automated service account, it cannot enter the CAPTCHA, leading to this error.
Solution
One of the below can be used to fix this problem:
Reset the failed login count by going to the Users page in JIRA Administration.
If you start seeing the failed logins again then we suggest verifying the credentials that the Jira Align service account uses to connect. You should be able to log directly into JIRA with those service account credentials.
If the password needs to be changed on Jira Align, then:
Navigate to Jira Align Administration > Jira Settings
Locate the Jira Connectors button on the upper right of the page, select the appropriate connector, and click the button to access the settings dialog.
Update the following, where applicable:
Jira Username
Jira Password or API Token
Save the settings.
Also, after the credential problem is fixed, no action is needed to sync the issues that failed during this period, as the connector will retry the transactions.