Internal server error when accessing the Issue Navigator and Admin areas

Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.

Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When browsing the Issue Navigator or any administration area, JIRA is redirecting the users to a non-existent page (secure/ThePageRequested) throwing an Internal Server Error.

Cause

In the server.xml file, the context path is configured as follows:

<Context path="/" docBase="${catalina.home}/atlassian-jira" reloadable="false" useHttpOnly="true">

Note the "/" in the path attribute. If there is no context path configured, that attribute be empty.

Resolution

  1. Stop JIRA.
  2. Edit the server.xml file and remove the slash, as the example below:
    <Context path="" docBase="${catalina.home}/atlassian-jira" reloadable="false" useHttpOnly="true">
  3. Start JIRA again.
Last modified on Jan 10, 2025

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