Jira System Administrators global permission is missing from Jira after restoring a backup from Jira Cloud


Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

After restoring a Cloud backup on Jira Server/Data Center, the Jira administrator cannot see some of the options under Jira Administration System. For instance, the Logging and profiling option is not available.

Environment

Jira Server/Data Center after restoring a Cloud backup.

Diagnosis

  1. Log in as a Jira administrator.
  2. Go to Jira Administration  System > Global Permissions.
  3. Check if you see the Jira System Administrators permission in the list and/or if you can add it from the dropdown list in the "Add Permission" section. You will notice the permission is missing from the global permission page.
  4. Trying the workaround in this KB doesn't help: Unable to edit Global Permissions after migrating from Atlassian Cloud.
  5. Running the SQL query below returns no result and shows the permission is missing also from the database:

    select * from globalpermissionentry where PERMISSION='SYSTEM_ADMIN'; 

Cause

The cause of this issue is still unknown but it's likely related to an inconsistency between the global permission management between Jira Cloud and Jira Server/DC.


Workaround

  1. Follow the steps in this KB article to put Jira in recovery mode.
  2. Log into Jira using the recovery_admin credentials.

  3. Navigate to Jira Administration  System > Global Permissions.
  4. You should see the Jira System Administrators permission now, but no group associated with it.
  5. At the bottom of the page, in the "Add Permission" section, grant the Jira System Administrators permission to the system-administrators group.
  6. Save the change.
  7. Once done, you can revert the change done in Step 1 and restart Jira.

 

Last modified on Sep 26, 2023

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