Closed issues do not show up in Advanced Roadmap Plans

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Platform Notice: Cloud, Server, and Data Center - This article applies equally to all platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Issues marked as "closed" do not show up in plans.

Diagnosis

To see if an Issue is 'closed' without a resolution, try adding the Resolution field to the Default Issue Screen for that project and then viewing the issue.

Resolutions can't be unset

Once a Resolution is set, it can be changed, but cannot be unset.

In general, issues marked "Done" have been set to that status with a transition that requires a Resolution, so this situation can be hard to arrive at.  This situation generally occurs when an Issue is closed with a direct edit to the status field or with a custom transition, though there are also other ways to arrive at this situation, such as by dragging an issue to 'closed' in a board, etc.

This article covers only closed issues without Resolutions.  If your issue is not closed, or has a value in the Resolution field, see Some issues are missing from plans in Advanced Roadmaps for Jira for other potential causes.

Roadmaps also refer to the "Resolved Date" field in the issue, and this field also needs to be set along with the "Resolution" field. By default, when the Jira issue is transitioned to "Close" or "Resolved" state by setting the Resolution field, "Resolved Date" is set.

Cause

Root Cause 1

If an Issue is closed but does not have a value in the Resolution field, the issue will not show up on a plan. Or, Parent issues, such as Epics, will not appear if all their children are closed without a resolution being set.

Root Cause 2

If an Issue is closed and the Resolution field has a value, but the Resolved date is not set, then the issue will not show up on a plan. This situation might occur if the Resolution field is set using:

  • Either a custom script (for example from a 3rd party plugin)
  • Or an Automation For Jira rule configured with the Edit Issue action. If the Edit Issue action is used to set the Resolution Field, the Resolved date field will not be set due to the bug linked below:

Solution

Solution For Root Cause 1

If a standard default workflow is in use, Transition the Issue to an In Progress state, then close the issue with a transition, which should require a Resolution to be set.

If using a custom workflow, create a screen to add to a Transition, and add the Resolution field to that screen.

For full instructions, see Edit the Resolution of Closed Jira Issues.

If many issues are in this state, they can be edited in bulk as described in Bulk edit resolutions in Jira.

Solution For Root Cause 2

If you are using a Script to set the Resolution Field of an issue, you will need to fix the script to ensure that the Resolved Date field is also set. Please note that such customization falls outside of Atlassian Support Offerings.

If you are using a rule from Automation For Jira to set the Resolution Field, you will need to set the Resolution field in the Transition Issue action instead of in the Edit issue action, as illustrated below:

Another option is to use the workaround from the Solution For Root Cause 1 section, which consists in setting the Resolution field via a workflow transition. Setting the Resolution field via a workflow transition will ensure that the Resolution Date field is set.


Last modified on Jun 19, 2024

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