Closed issues do not show up in Advanced Roadmap Plans
Platform Notice: Cloud, Server, and Data Center - This article applies equally to all platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Issues marked as "closed" do not show up in plans.
Diagnosis
To see if an Issue is 'closed' without a resolution, try adding the Resolution field to the Default Issue Screen for that project and then viewing the issue.
Resolutions can't be unset
Once a Resolution is set, it can be changed, but cannot be unset.
In general, issues marked "Done" have been set to that status with a transition that requires a Resolution, so this situation can be hard to arrive at. This situation generally occurs when an Issue is closed with a direct edit to the status field or with a custom transition, though there are also other ways to arrive at this situation, such as by dragging an issue to 'closed' in a board, etc.
This article covers only closed issues without Resolutions. If your issue is not closed, or has a value in the Resolution field, see Some issues are missing from plans in Advanced Roadmaps for Jira for other potential causes.
Cause
If an Issue is closed but does not have a value in the Resolution field, the issue will not show up on a plan.
Solution
If a standard default workflow is in use, Transition the Issue to an In Progress state, then close the issue with a transition, which should require a Resolution to be set.
If using a custom workflow, create a screen to add to a Transition, and add the Resolution field to that screen.
For full instructions, see How to Edit the Resolution of a Jira Issue.
If many issues are in this state, they can be edited in bulk as described in Bulk edit resolutions in Jira.