Jira Data Center - Created vs. Resolved chart showing incorrect count of resolved issues

Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.

Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

The chart is showing 0 issues being resolved or the resolved issues count is incorrect.

Environment

Jira Data Center on any version from 8.0.0.

Cause

It could be either one of the causes:

  • The Resolution field is hidden in the Field Configuration for the affected Issue Type or Project. If the Resolution field is hidden, the functionalities that related to the Resolution field will be lost.
  • The Resolution field is not added into the Resolve issue screen.

Resolution

Show the Resolution in the Field Configuration associated to the Issue Type or Project as per Specifying field behaviour, by following the steps below:

  1. This can be done by navigating to "Administration → Issues → Field Configurations" page. 
  2. Choose the one used by your project and then click on "Configure".
  3. Make sure the "Resolution" field is not hidden. If this is hidden an option to "Show" will appear, in our case it's not hidden. Hence we have an option to "Hide" this field.
  4. Now confirm that the "Resolution" field is added to the Resolve issue screen for the specific projects where required.
  5. Reindex JIRA instance for changes to be effective since this is configuration change.


Last modified on Jan 6, 2025

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