User receives repeated CAPTCHA prompts on login to Jira server

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

The user is presented with a CAPTCHA on the login page. After entering the CAPTCHA and trying to login again, the following error "Sorry, your userid is required to answer a CAPTCHA question correctly" is displayed:

Cause

This problem might be caused due to the browser cookies, or by too many failed attempts.

Resolution

  1. Delete the browser cookies and site data.
  2. Refresh the login page and try to log in again.
  3. If the problem persists, check the atlassian-jira-security.log for failed authentication messages like this one below. A service could be using old credentials and make the CAPTCHA show up - the log will show if that's the case.

    /rest/gadget/1.0/login The user 'myuser' has FAILED authentication.  Failure count equals 3


(info) Keep in mind that the number of requests for Jira to show a CAPTCHA is set in System > General configuration and blank means the CAPTCHA is disabled.


To reset the failed user count, follow the steps on https://confluence.atlassian.com/jirakb/reset-failed-user-login-count-442270086.html.

Last modified on Feb 22, 2024

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