This documentation relates to SharePoint Connector 1.9
If you are using an earlier version, please view the previous versions of the SharePoint Connector documentation and select the relevant version.

Skip to end of metadata
Go to start of metadata

Below are some important notes on upgrading to SharePoint Connector 1.2 from an earlier version of the connector. For details of the new features and improvements in this release, please read the SharePoint Connector 1.2 Release Notes.

On this page:

Upgrade Notes

Minimum Requirement is Confluence 2.10.0 or Later

With the release of version 1.2, the SharePoint Connector no longer supports Confluence 2.8.x or 2.9.x. The minimum requirement is Confluence 2.10.0 or later. Please refer to the full details of the supported platforms for SharePoint 2007 and for SharePoint 2010

Configuration Settings in SharePoint 2010 must be Reapplied

The configuration settings applied to Confluence during the installation of previous versions of the SharePoint Connector will remain untouched and will continue to apply to the new version of the Connector once you have installed it.

If you are upgrading to the latest version of the SharePoint Connector but remaining on Microsoft SharePoint 2007, then the configuration settings in SharePoint will also survive the upgrade.

If you are moving to Microsoft SharePoint 2010, you will need to reapply the configuration settings in SharePoint. See the upgrade guide for instructions.

One Installer

The SharePoint Connector zip file provides one installer (Setup_WebParts.exe) that works for both SharePoint 2007 and SharePoint 2010. The installer will detect the version of SharePoint installed on your machine.

Upgrade Procedure

There are two upgrade procedures to choose from:

  • Option 1: Upgrade your SharePoint Connector on SharePoint 2010. This procedure assumes that you have upgraded your SharePoint server to Microsoft SharePoint 2010. To upgrade the connector, you will install the latest version of the SharePoint Connector plugin in Confluence and upgrade the SharePoint feature in Microsoft SharePoint 2010. See the instructions.
  • Option 2: Upgrade your SharePoint Connector on SharePoint 2007. This procedure assumes that you are running the SharePoint Connector on Microsoft SharePoint 2007. To upgrade the connector, you will install the latest version of the SharePoint Connector plugin in Confluence and upgrade the SharePoint feature in Microsoft SharePoint 2007. See the instructions.

Need help?

If you encounter a problem during the upgrade, please create a support ticket and one of our support engineers will assist you through the process.

RELATED TOPICS

SharePoint Connector 1.2 Release Notes

  • No labels