Crowd 2.9.1 Upgrade Notes

This document contains notes on upgrading an existing Crowd installation to Crowd 2.9.1 or later. We highly recommend that you read the new features described in the Crowd 2.9.1 Release Notes.

On this page:

Upgrade notes

Please read the following sections and take action where the note applies to your Crowd installation, before upgrading to the new release of Crowd.

Java 8 is required

Crowd 2.9.1 requires Java 8 to run. You can upgrade or install Oracle JDK 8 or OpenJDK 8.

Please note that JDK versions older than 8u65 may have problems connecting to LDAP servers over SSL - see  CWD-4444 - Secure LDAP connections are broken when using Java 1.8u51, 1.8u60, 1.7.0_85+ and 1.6.0_101+ Resolved  for more information.

Refer to the Crowd 2.8 upgrade notes

If you have not yet upgraded to Crowd 2.8, please read the Crowd 2.8 upgrade notes before upgrading to Crowd 2.9.1

Configuring compression of server output is no longer supported

As of Crowd 2.9.1 configuring Compression of Server Output is no longer supported. All responses will be gzip compressed by default

Plugin developers only - Plugins 4.0 upgrade

Crowd 2.9.1 ships with an upgraded plugins system. Please refer to the Atlassian Plugins 4.0 Upgrade Guide for a detailed list of changes introduced by the upgrade.

Upgrade procedure

To upgrade to a Crowd 2.9.x release from any earlier version of Crowd, please follow these upgrade instructions.

Was this helpful?

Thanks for your feedback!

Why was this unhelpful?

Have a question about this article?

See questions about this article

Powered by Confluence and Scroll Viewport