Bitbucket Server does not send emails after a restart
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the server and data center platforms.
Problem
After restarting Bitbucket Server, no notification emails are being sent.
The following appears in the atlassian-bitbucket.log
2014-05-01 09:27:21,749 ERROR [localhost-startStop-1] c.a.plugin.manager.PluginEnabler Unable to start the following plugins due to timeout while waiting for plugin to enable: com.atlassian.bitbucket.server.bitbucket-notification
Cause
The Bitbucket Server Notification plugin has failed to enable and no emails are being sent. This is likely caused by corrupted plugin cache.
Workaround
Attempt to re-enable the Bitbucket Server Notification plugin under Administration >> Manage add-ons >> All add-ons
.
Resolution
Clear the plugin cache by doing the following:
- Stop Bitbucket Server
- Delete
<BITBUCKET_HOME>/plugins/.bundled-plugins
and<BITBUCKET_HOME>/plugins/.osgi-cache
(these will be recreated on startup) - Start Bitbucket Server