Create support zip fails with timeout message

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Symptoms

After creating a Support Zip, the following appears in the Stash UI:

Your request timed out. Please try again. If you're sending a support request, please check your mail settings.

Cause

This is a bug on the Support Tools Plugin for when the Support Zip is too big:  Unable to locate Jira server for this macro. It may be due to Application Link configuration.

Resolution

Although that message is reported by the plugin, the file is generated within your $STASH_HOME/export directory. Please monitor this directory as the file is built in memory and written to the disk in one go - thus you'll notice the file with 0 bytes size until the plugin is finished.

Last modified on Mar 30, 2016

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