Documentation for JIRA 6.4 (This documentation includes the project navigation sidebar). Not using this? See below:
(JIRA 6.4 without sidebar documentation | JIRA 6.3.x documentation | JIRA Cloud documentation | earlier versions of JIRA)

Skip to end of metadata
Go to start of metadata

Do not use in production

EAP releases should not be used in production environments as they are not officially supported.

Please also take note of the following information:

  • EAP Releases are Not Safe— EAP releases are snapshots of the ongoing JIRA development process. As such:
    • While we try to keep these releases stable, they have not undergone the same degree of testing as a full release.
    • Features in development releases may be incomplete, or may change or be removed before the next full release.
  • No Upgrade Path — Because EAP releases represent work in progress, we can not provide a supported upgrade path between EAP releases, or from any EAP to the eventual final release. Thus, any data you store in a JIRA EAP release may not be able to be migrated to a future JIRA release.

JIRA 3.11 EAP is a public development release leading up to JIRA 3.11.

Who should download this release?

This EAP release is being made available specifically for JIRA plugin developers to test their existing plugins against indexing changes in JIRA 3.11. This affects all plugins that maintain their own indexes or interact with JIRA's index (e.g. via a custom field with a custom searcher that the plugin implements).

For all production use and testing of JIRA, please use the latest official release.

Plugins that depend on indexing will have to be updated to remove the use of any methods that were deprecated in Lucene 1.9.1. These plugins will have to be re-compiled against Lucene 2.2.0 and re-released for JIRA 3.11.

What's new?

This EAP release includes the following features:

JIRA 3.11 aims to upgrade Lucene to version 2.2.0. A number of deprecated methods that JIRA and JIRA plugins relied on where removed from this version of Lucene. Aside from the API changes, there were also changes to how certain fields are stored in the index themselves. Luckily Lucene 2.2.0 is backwards compatible and is able to read indexes created by earlier versions of Lucene (indexes will be converted to the Lucene 2.2.0 format as soon as documents are added). Once an index has been upgraded to Lucene 2.2.0 any previous version of Lucene will not be able to read this index any longer.

One change that may require you to re-index are how dates are stored in the index. For example, DateFields have been deprecated in favour of DateTools, which stores dates in a human readable form. If you convert your plugins to store dates using DateTools, you will need to advise all users that they will need to perform a re-index (currently the only way to do this for plugins is to delete the plugin's index files).

What should I do?

If you have developed custom plugins that use Lucene, either publicly in the JIRA Plugin Library, or privately for you company's internal use, it is critical that you test those plugins against the JIRA 3.11 EAP. Because of the upgrade Lucene 2.2 and the large number of deprecations, it is likely that you will need to make changes.

You should make any necessary changes to the plugin, and be prepared to release thhose fixes in conjunction with JIRA 3.11, so that users will have a smooth upgrade experience.

If you have any trouble with the EAP or the upgrade process, please contact developer-support@atlassian.com for assistance.

The EAP is available for download here.