Confluence 2.10 Upgrade Notes

Below are some essential notes on upgrading to Confluence 2.10. For details of the new features and improvements in this release, please read the Confluence 2.10 Release Notes.

On this page:

Upgrade Notes

Enabling the New Quick Navigation Feature on Customized Confluence Sites

If you have customized your Main Layout on either the space or the global level, or if you have a custom theme plugin, the new quick navigation feature will not work immediately for you.

To enable quick navigation, you need to add the following statement to your Main Layout anywhere before the #standardHeader() statement:

#requireResourcesForContext("main")

Crowd and the User Search

Confluence 2.10 includes a much-enhanced user search. (See the release notes.) If you are using Atlassian's Crowd for user management, you will need Crowd 1.5.1 or later to use the 'Simple' option in the user search. If your version of Crowd does not support the simple user search, you will see only the 'Advanced' search form. Please consider upgrading your Crowd version, to take advantage of the advanced user search.

RSS and HTML macro whitelists

To improve the security of a default installation of Confluence, macros which display HTML from external sources now use a whitelist of URLs configured by the Confluence administrator. This affects the RSS and HTML include macros.

See Configuring a URL Whitelist for Macros for instructions on how to configure a list of allowed URL patterns for the RSS and HTML macros in Confluence 2.10.

Plugins

If you are using any third-party plugins on your Confluence instance, please test them thoroughly before rolling 2.10 into production.

Java Versions

Java 1.4 is not supported in Confluence 2.9 and later. Please refer to the Java 1.4 Support Timeline for more information.

Before upgrading to Confluence 2.10, you will need to ensure your environment is running at least Java 5. Confluence 2.10 supports Java 5 and Java 6. We recommend Java 6 because of its increased performance and easier troubleshooting, due to enhanced memory dump and profiling capabilities.

You can check your current Java version in Confluence:

  1. Choose the cog icon , then choose General Configuration under Confluence Administration
  2. Select 'System Information' from the 'Administration' section in the left-hand panel.
  3. Refer to 'Java Version'.
    • If the version is 1.5 or higher, you do not need to do anything.
    • If the version is 1.4, you need to upgrade your JDK before you can upgrade to Confluence 2.10.

If you are running the Confluence EAR-WAR edition against your own application server, you will need to check with your application server vendor about which JDK versions are supported.

Platforms No Longer Supported

The following platforms were on the 'unsupported but working' list for Confluence 2.9. They are not on that list as of Confluence 2.10. We will still test those platforms infrequently, and Confluence will probably still work fine with them for a while, but they will not be officially supported.

  • MySQL 4.1 — please upgrade to MySQL 5
  • Tomcat 5.0 — please upgrade to Tomcat 5.5 or 6
  • Resin 2 — please upgrade to Resin 3
  • JBoss 4.0.x — please upgrade to JBoss 4.2.x

Please refer to the list of supported application servers and databases on our Supported Platforms topic for the updated matrix.

There is a workaround to enable MySQL 4.1.x.

JavaScript Libraries

jQuery is the supported JavaScript library for plugin developers.

Advance notice — deprecated libraries: We have decided to standardize on jQuery as the JavaScript library for Confluence. This library will eventually replace all others. For this reason, use of the following JavaScript libraries in Confluence is deprecated:

  • Prototype
  • Scriptaculous

Because there is a lot of legacy plugin code using Prototype and Scriptaculous, these will continue to be available for this release of Confluence.

The Yahoo! User Interface Library (YUI) is no longer supported, following its removal in Confluence 2.9.

Confluence Themes

The Confluence Classic Theme is no longer supported, following its deprecation in Confluence 2.9. This theme uses outdated typography and formatting, which was replaced by the new-look Default Theme in Confluence 2.6. At that time, we introduced the Classic Theme to minimize the impact on customers who relied on the older typography.

When you upgrade to Confluence 2.10, an upgrade task runs to do the following:

  • Any space with the Classic Theme configured will be migrated to use the Default Theme.
  • If your Global Theme is set to use the Classic Theme, the Global Theme is also migrated to the Default Theme.
  • The Classic Theme plugin is uninstalled. (The Classic Theme entry in the database is removed.)

End of Life of SnipSnap Import

Advance notice — EOL SnipSnap import: Confluence 2.10 is the last release which will include the SnipSnap Import option in the Confluence Administration Console. From the next release after Confluence 2.10, the SnipSnap import will no longer be available.

No Need to Re-Create Database Indexes Manually

In previous releases of Confluence, you needed to manually re-create the database indexes during the upgrade procedure. For this purpose, we provided a set of SQL statements as an attachment to the Upgrade Guide. From Confluence 2.10, the upgrade process will automatically re-create the indexes. Please refer to the Upgrade Guide.

Upgrade Procedure

Upgrade a test environment first

As always, please test your upgrades in your test environment before rolling into production.

If you are already running a version of Confluence, please follow these instructions to upgrade to the latest version:

  1. Before you upgrade, we strongly recommend that you back up your Confluence Home and database. See the documentation on backing up your Confluence site. If you are using an external database, perform a database backup.
  2. If your version of Confluence is earlier than 2.9.x, read the release notes and upgrade guides for all releases between your version and the latest version. In particular:
    • Please read the 2.9 upgrade notes.
    • If you are upgrading from 2.1 or earlier, please read the 2.2 release notes.
    • If you are upgrading from 2.2 or earlier, you will need to upgrade to Confluence 2.5.8 first, confirm the upgrade was successful, then upgrade again from version 2.5.8 to the latest. For more details, please refer to CONF-11767.
  3. Download the latest version of Confluence.
  4. Follow the instructions in the Upgrade Guide.
  5. If you encounter a problem during the upgrade, please create a support ticket and one of our support engineers will assist you through the process.
RELATED TOPICS

Confluence 2.10 Release Notes

Was this helpful?

Thanks for your feedback!

Why was this unhelpful?

Have a question about this article?

See questions about this article

Powered by Confluence and Scroll Viewport